Frispel

sedan 2001

Indiana Jones Switch Problem

larson

  • Full Member
  • ***
    • Antal inlägg: 143
    • Visa profil
  • Stad: Stockholm
Hej

Mitt IJ spel får för sig att göra "Ball Locks" lite när den vill och därmed skicka ut extra bollar.

Spelet registrerar inga errors i testrapporten och när man manuellt går igenom Switch Edges testet så verkar allt i sin ordning även där. ( Har även studerat tested medans jag har slagit runt på flippret för att se om jag kan hitta nåt glapp. )

Jag försökte rengöra den opto switch som ligger under "Ball Lock" hålet ( mittenhålet ) men en öronpetare men det verkar bara ha gjort saken värre.

Kanske borde byta ut opto switchen helt och hållet? Kan det vara en kortslutning i switch matrisen och betyder det att spelet är helt värdelöst?

Är det någon som har några tankar kring detta? Var får jag tag på en ny opto switch till Indy här i sverige, vad brukar de kosta?

Supertacksam för all kunskap ni kan förmedla!


Mr M

  • Sr. Member
  • ****
    • Antal inlägg: 366
    • Visa profil
  • Stad: Malmö
Hej,
Jag tror inte att problemet ligger i optoswitcharna kring just lock-hålet, utan optoswitcharna i bollmagasinet. Kontrollera kretskorten ordentligt. Genom att skruva av dom kommer du lättare åt. Dom vanligaste problemen brukar finnas på det kortet närmast dig, dvs sändarkortet. Kolla in baksidan, och var uppmärksam på kallödningar eller lösa komponenter, främst IR-dioderna och dom stora motstånden. Smält gärna om lödpunkterna så att du får en solid lödning.

Jag har dessa delar för omg leverans. Du kan maila mig om du har frågor.

Håkan Malmberg
info@pinballsweden.se

M


larson

  • Full Member
  • ***
    • Antal inlägg: 143
    • Visa profil
  • Stad: Stockholm
hmmm... jag har nu tittat på optoswitcharna både i bollmagasinet men inte hittat något fel där heller...

Grejen är att spelet kör en hel "Ball lock" animation innan det släpper nya bollar. ( Och bollarna kan lika gärna komma från statyn som från plungern. )

Min nuvarande teori är inte att optoswitcharna strular utan att det är nån utav de två vanliga switcharna i loopen längst ut till höger på spelplanen. Spelet verkar strula till det för sig när bollen kör över nån av dessa...

Finns det något sätt att enkelt koppla ifrån dessa två switchar temporärt för lite felsökning? ( A-12688 switchar ) Utan att riskera nån skada vill säga.

Är det möjligt för en trasig switch att ge ifrån sig en "felaktig" signal och trigga fel funktioner eller måste den vara felkopplad/kortslutet någonstans?

Tack på förhand.
« Senast ändrad: oktober 09, 2003, 12:11:03 av larson »


Mr M

  • Sr. Member
  • ****
    • Antal inlägg: 366
    • Visa profil
  • Stad: Malmö
Låter som om du har en skum switch någonstans i samma rad/kolumn som locken. Kolla så att dioderna på loop-switcharna fungerar som dom ska, om dom switcharna ligger i samma "lina" så kan det vara där spöket sitter.

M


larson

  • Full Member
  • ***
    • Antal inlägg: 143
    • Visa profil
  • Stad: Stockholm
De två loopswitcharna som jag misstänker strula ligger inte på samma rad eller kolumn i switch matrisen... Så jag får försöka felsöka lite mera...

Jag får nog börja råplugga elteknik eller vad det nu kan heta låter det som... Jag visste att jag skulle valt ett annat yrke! Attans. :)
« Senast ändrad: oktober 09, 2003, 19:12:14 av larson »


LDK

  • Hero Member
  • *****
    • Antal inlägg: 2226
    • Visa profil
  • Stad: Uppsala

demand

  • Newbie
  • *
    • Antal inlägg: 6
    • Visa profil
  • Stad: Linköping
Har du testat att knacka med typ handtaget på en större skruvmejsel på ballmagasinet, kan vara så att switcharna funkar när man inte spelar men när det blir skakningar så ballar dom ur. Hade det problemet på ett IJ.
Ställ in switch edges i menyn och knacka lite försiktigt och kolla om nån switch reagerar.
Kan ju vara opton som sitter i ball lock som är glapp.

/Krille


larson

  • Full Member
  • ***
    • Antal inlägg: 143
    • Visa profil
  • Stad: Stockholm
TJOHO!

Nu har problemet löst sig. Efter MYCKET felsökande kom jag på att det inte var de två switcharna i den högra loopen utan ett glapp i en Opto uppe i Inkastatyn som skapade felet. ( Eftersom statyn sitter precis vägg i vägg med loopen så kunde den glappa till ibland när kulan slog i väggen på väg genom rampen! )

PUST!

Så nu är spelet prickfritt och i ypperligt skick igen! Nu behöver jag bara två tre lampor så är spelet nästan som nytt!

Tack för alla råd och tips!