Frispel

sedan 2001

Ännu mer displayproblem

Grandelius

  • Hero Member
  • *****
    • Antal inlägg: 1514
    • Visa profil
  • Stad: Stockholm
Nu är det riktigt illa!
När jag slog på Congo idag var displayen bara helt död! Ingenting alls händer.
Har försökt se om jag kan hitta något på egen hand, men inte funnit någonting. Lysdioderna på korten lyser som de ska, alla säkringar är hela, och sladdarna som går fram till displayen är hela. Den lilla kablen (gissar att den bara skickar information) har jag inte lyckats mäta på, eftersom jag inte kom åt, men det känns inte troligt att den skulle ha lagt av helt plötsligt. Igår kväll funkade den som vanligt. Det enda annorlunda jag kan minnas är att jag kanske (är inte riktigt säker) stängde av spelet med myntluckan öppen. Men det kan väl ändå inte spela någon roll?

Vad kan ha hänt? Displayen dör väl inte bara så där rakt av?
Mighty Leader of the Junk Yard Fanclub


Grandelius

  • Hero Member
  • *****
    • Antal inlägg: 1514
    • Visa profil
  • Stad: Stockholm
En uppdatering:
Läste på Marvin och fann lite tips om hur jag ska mäta på displayen. Jag mätte på det sättet och fick ett rätt konstigt resultat. Pinnarna 1 och 2, som ska ha -125 och -113 volt gav endast -0,7 respektive -0,3 volt. I det närmaste ingening alltså. De andra pinnarna ger exakt rätt utslag. Vad kan detta bero på?

Det enda jag kan se på Marvin-sidan är:
Citera
Both the -125 and the -113 volts are the same voltage.
The dot matrix display will not work if both the -125 volts and -113 volts measure as the same voltage. These two negative high voltages should be 12 volts apart. The difference in voltage occurs because of diode D6 (D3 on WPC-95), a 12 volt 1N4742 diode. The failure of this diode also kills transistor Q7 (known as Q7 in all WPC generations, a MJE15030). The -125 volts and -113 volts must be 12 volts apart, or the dot matrix display will not work!

Detta känns som att det handlar om något annat. Visserligen ligger ju spänningen på mindre än 12 volts skillnad, men det står ju inget i texten om extremt låg spänning.
Är det helt enkelt någon komponent som gett sig på A/V-kortet nu igen?
Mighty Leader of the Junk Yard Fanclub


Tjernell

  • Sr. Member
  • ****
    • Antal inlägg: 257
    • Visa profil
  • Stad: Eskilstuna
Hej
Tag en säkring av lämplig kaliber ( lämpligt med en 5 Amps slowblow ) och nu tänker du sisåhär att en sån har jag inte i verktygslådan men den kan du låna från G.I ( General iluminum ( reservation för felstavning ) och därefter trycker du den på alla säkringar utom lågspänningen till CPU:kortet som är en liten vek säkring som sitter på powerkortet ( den säkringen är så vek att om den har gått så kan du skada spelet ytterligare med en så kraftig säkring ). Alternativen som inträffar när du "bryggar" över säkringarna är följande:

1. Aj fan jag fick en stöt = håll på glaset av testsäkringen eller använd ett lämpligt verktyg)

2. Ingenting ( Grattis den säkringen är hel )

3. Säkringen gör ett dåligt försök att fungera som glödlampa ( du är något på spåren )

Hittar du ingenting med denna metod så tar du och trycker/bryter försiktigt på alla kontakter för att hitta glapp.

Ta loss alla kort i tur och ordning och titta efter skumma lödningar, börja med fördel vid den kontakt som leder ner till displayen.

Kontrollera likriktaren som matar spänningen till displayen.

Hjälper inte detta så tar du fram ett lämpligt verktyg och slår sönder hela skiten:-D

mvh Johan


Grandelius

  • Hero Member
  • *****
    • Antal inlägg: 1514
    • Visa profil
  • Stad: Stockholm
Säger ett sådant här test något mer än om säkringarna är hela? För jag har mätt på alla säkringar och de verkade hela då.
Men desperat som jag är testar jag väl allt som går då...

Det som är så skumt är att det inte började när spelet var igång, utan den bara var död när jag slog på det. Om det vore glapp eller något sådant borde det väl liksom komma och gå lite först?

Jag kan dock säga att det där sista inte känns som en alltför tilltalande lösning :-D
Citera
och nu tänker du sisåhär att en sån har jag inte i verktygslådan
Jo, faktiskt tror jag att jag fick med några sådana med senaste beställningen från P4P. :-)
Mighty Leader of the Junk Yard Fanclub


Tjernell

  • Sr. Member
  • ****
    • Antal inlägg: 257
    • Visa profil
  • Stad: Eskilstuna
Hej
Problemet med att mäta på säkringarna är att det ofta verkar hela för att du får kontakt genom kortet, denna metod är skitbra och jag använder den i stort sätt alltid när jag kontrollerar säkringar. En annan fråga, fungerar spelet precis som vanligt men med död display? Har du fler funderingar så ring 070-3785521 för nu går jag hem. mvh Johan
« Senast ändrad: januari 26, 2005, 21:20:39 av Tjernell »


kniven

  • Hero Member
  • *****
    • Antal inlägg: 1242
    • Visa profil
  • Stad: Träslövsläge
Angående mäta säkringar, jag brukar ta en multimeter och sätta ena pinnen mot en lämplig jordfläta (underkant på bakboxen är en lättåtkomlig). Ta sedan den andra (pluspinnen är att föredra då +- spänningarna stämmer med schemat) och mät på ena sedan andra sidan av varje säkring. Spänningen skall vara exakt samma på båda sidor om säkringen, annars byt. Ingen risk att bränna något kort om man gör så här.
Men jag misstänker nog mer en av zenerdioderna på DMD-kortet...


EDIT: Spelet skall vara igång.
« Senast ändrad: januari 26, 2005, 21:26:14 av kniven »


Grandelius

  • Hero Member
  • *****
    • Antal inlägg: 1514
    • Visa profil
  • Stad: Stockholm
Nu har jag testat på både Tjernells och Knivens sätt. Det jag kom fram till var att säkring F602 på A/V-kortet beter sig klart misstänkt. Den verkade trasig när jag testade första gången på egen hand också, men så plockade jag ut den och mätte, och då tycktes den ändå hel. Skumt.
Hursomhelst, med Tjernells metod blixtrade det till lite när jag förde säkringen mot, och knivens metod gav olika spänningar. Det som ytterligare tyder på att den har med saken att göra är att det i manualen står att den är för "-113V & -125V" (Sherlock slår till igen :-D). Tyvärr så tillhör denna säkring så klart en typ jag inte har (25A). Får väl titta om jag hittar något konstigt på kortet.
Var hittar man förresten sådana här säkringar? Inte ska man väl behöva vända sig till flipperdetaljister? Är det något som finns på en bensinmack, eller är det mer TV-reparatörer som använder denna typ av säkringar?

Som svar på Tjernells fråga kan jag säga att ja, det verkar funka som vanligt. Har inte testat att dra igång något spel, men det lär väl bli en rätt egen variant av blindflipper antar jag :-)
Mighty Leader of the Junk Yard Fanclub


Grandelius

  • Hero Member
  • *****
    • Antal inlägg: 1514
    • Visa profil
  • Stad: Stockholm
Man känner sig inte så lite amatörmässig just nu...

Säkringen var visst inte alls på 25A, utan på 0,25A. En VISS skillnad kanske. Nu är jag till att börja med orolig för om jag kan ha förstört något genom att hålla 4A-säkringen ovanpå. Det borde väl släppa fram alldeles för mycket ström om något är fel? Och att det blixtrade till när jag testade gör inte att det känns bättre. Men jag tror att det var säkringen som blixtrade.

Funderade på det här med zenerdioderna också. Hur ska man mäta på dessa? Är det inte så att de bara funkar vid en viss spänning, och att man alltså måste testa med spelet igång?

Har försökt titta på det här kopplingsschemat, men tyvärr är jag inte säker på att jag blir så mycket klokare på vad som kan ha gått sönder.
Mighty Leader of the Junk Yard Fanclub


Tjernell

  • Sr. Member
  • ****
    • Antal inlägg: 257
    • Visa profil
  • Stad: Eskilstuna
Tjabba
Oroa dig inte så mycket utan rodda fram en ny säkring ( med fördel en aningen men inte för mycket grövre ) och smacka dit den och kolla vad som händer. Troligtvis så kommer spelet att funka som vanligt. Jag misstänker att du har fått en liten strömrusning när du startade ditt spel som knäckt säkringen. mvh Johan


iceman

  • Hero Member
  • *****
    • Antal inlägg: 1199
    • Visa profil
  • Stad: Sundsvall
Spänningen över en zenerdiod skall vara den som den är märkt för när spelet är igång. Dvs 7,2 V om den är märkt 7,2. Om du lyfter ena benet på dioden skall den mäta 0,6 ungefär åt ena hållet vid diodmätning. Om du ohm-mäter visar den oändligt åt ena hållet och något annat åt det andra. Allt detta för hela dioder.

Säkringarna bör vara tröga. De du hittar på mackarna (eller egentligen inte alls där längre) är troligen snabba.


Grandelius

  • Hero Member
  • *****
    • Antal inlägg: 1514
    • Visa profil
  • Stad: Stockholm
Jag var nu precis iväg och köpte lite säkringar på Mekonomen (en timmes promenad :-P). Huruvida de är tröga eller inte har jag ingen aning om. Men det första jag gjorde när jag kom tillbaka var att sätta i en, sätta på spelet och se den blixtra till så där retligt. Jag köpte en på 0,5A också. Vågar jag sätta i den och testa, eller är det för starkt?

Känns som det kommer dröja innan jag får igång den där displayen. Suck!
Får väl börja mäta på dioderna nu då.

Tack så mycket för all hjälp i alla fall! Det är ovärderligt!
När jag blir stor ska jag också veta så där mycket! :-D
Mighty Leader of the Junk Yard Fanclub


Grandelius

  • Hero Member
  • *****
    • Antal inlägg: 1514
    • Visa profil
  • Stad: Stockholm
På Marvin-sidan fann jag följande:
Citera
Make sure to check fuses F601 and F602 (all WPC games). F601 is used for +62 volts, and F602 is used for -113, -125 volts. On WPC-S and before, these are 3/8 amp fast-blo 1.25" fuses (originally Williams used slow-blo fuses here, but about 1994 they changed to fast-blo, so either fast or slow-blo can be used). On WPC-95, these are T0.315 amp 5x20mm fuses.
0,315A alltså. Enligt manualen är det ju 0,25. På Mekonomen var 0,5 det minsta efter 0,25. Vågar jag testa?

För övrigt kunde jag konstatera att det bara var en zenerdiod som gav vettigt utslag. Men det kanske beror på att de inte får någon ström för säkringen?
Mighty Leader of the Junk Yard Fanclub


Grandelius

  • Hero Member
  • *****
    • Antal inlägg: 1514
    • Visa profil
  • Stad: Stockholm
Vet inte alls hur jag ska fortsätta. Min tanke nu är att jag skulle ta och beställa en uppsättning nya komponenter till högspänningsdelen av kortet. Antar att det är lika bra att byta hela rasket. Eller?
Det tråkiga (förutom att det blir en massa jobb) är ju att det kommer synas ganska väl att man har varit framme och pillat. Men Marvin rekomenderar ju att man byter allt.

Sedan hittar jag inte alla zenerdioder på Elfa. Funkar de för 5w lika bra som 1w? Det borde de väl göra?

Sedan slog det mig att det skulle kunna finnas ett samband med att jag bytte de där kondensatorerna. Det är inte så att dessa skulle kunna förstöra allt igen om jag nu lyckas fixa det?
Mighty Leader of the Junk Yard Fanclub


kniven

  • Hero Member
  • *****
    • Antal inlägg: 1242
    • Visa profil
  • Stad: Träslövsläge
Sist jag bytte på ett kort bytte jag allt utom några motstånd borta vid kondensatorerna.
Priset för ett 'High-powerkit' hos, tex, P4P är mycket bra jämfört med att köpa motsvarande komponenter hos ELFA.
Kortet funkade finfint efter de nya komponenterna.


Grandelius

  • Hero Member
  • *****
    • Antal inlägg: 1514
    • Visa profil
  • Stad: Stockholm
Citera
Priset för ett 'High-powerkit' hos, tex, P4P är mycket bra jämfört med att köpa motsvarande komponenter hos ELFA.
Jo, det noterade jag. Men om jag beställer därifrån kanske jag får det framåt slutet på nästa vecka, men om jag beställer från Elfa idag får jag det kanske på måndag eller tisdag. Har inte bestämt mig för om det är värt det än. Det känns som det ändå kommer ta någon vecka att byta alla de där komponenterna.

Men du tycker också att jag ska byta allt?
Mighty Leader of the Junk Yard Fanclub