Frispel

sedan 2001

Displayproblem

AFR

  • Newbie
  • *
    • Antal inlägg: 38
    • Visa profil
  • Stad: Mölndal
För ett tag sen köpte jag ett WPC-spel där allt verkade bra när jag provspelade det. Men efter att ha fraktat hem och startat spelet såg displayen ut så här efter knappt 30 minuter (blir likadant varenda gång efter ungefär samma tid).
Display

Eftersom säljaren aldrig råkat ut för detta undrar jag vad som kan ha hänt pga. flytten av spelet?

Började med att mäta upp spänningarna till displayen (som var inkopplad), och de låg alla inom toleransen för var pinrepair.com säger. Men skillnaden mellan pin1 & pin2 var inte 12 V (som pinrepair säger att den ska vara) utan ca 23 V (pin1=-124 V & pin2=-101 V). Därför har jag bytt ut komponenterna på kontrollkortet, inkl. de två stora kondensatorerna, som har med högspänningen att göra.

Eftersom bl.a. två av de fyra 47 kOhm:s motstånden (till vänster om de båda stora kondingarna) var trasiga (avbrott) trodde jag först på att renoveringen av kontrollkortet skulle lösa det hela. Men det hjälpte tyvärr inte. Kopplade in displayen, startade spelet och mätte pin1=-116 V & pin2=-94 V (alltså betydligt mer än 12 V skillnad).

Kort,
Kort1, Kort2, Kort3

Är det så att en dålig display kan belasta displaykontrollkortet så att det blir på detta sätt, och att displayen på något sätt gick sönder vid transporten, eller kan det vara något annat? Eftersom några av komponenterna på kontrollkortet var mer eller mindre grillade innan jag bytte dom vågar jag inte testa alltför mycket med denna display, t.ex. testa den i ett annat spel (med risk för ny grillning).

Har nu även testat med en annan display i spelet, och då blir det bättre, pin1=-117 V & pin2=-105 V. Hade den displayen igång i ca 2 timmar med stabila spänningar och utan andra problem.

Men innan jag ger upp. Kan det vara något annat som spökar, eller kanske någon komponent eller lödning på kortet som displayen sitter fastlödd på som behöver bytas eller lödas om?

Någon som har nån ide?


COCS

  • Hero Member
  • *****
    • Antal inlägg: 4378
    • Visa profil
  • Stad: Göteborg
Jag tror din display är dålig. Prova att byta till en fräsch display - låna av ngn.

Är det ett WPC-95 spel, så är det en kondensator som behöver bytas på A/V-kortet.

Jag läste bara snabbt, så jag kanske missade om du skrev vilket spel det är.
COCS
Carl Olof Christian Sjöberg
Tel: 073-902 19 12
Jag är stolt ägare till Vampire, Fireball, Nip-It & 2x4MBC :-D


ARE

  • Hero Member
  • *****
    • Antal inlägg: 941
    • Visa profil
  • Stad: OSLO
hmm

Citera
Har nu även testat med en annan display i spelet, och då blir det bättre, pin1=-117 V & pin2=-105 V. Hade den displayen igång i ca 2 timmar med stabila spänningar och utan andra problem.


For meg høres det ut som dårlig display nr. 1. Men har du forsøkt med display nr. 1 i et annet WPC spill?
« Senast ändrad: januari 25, 2009, 22:51:16 av ARE »


AFR

  • Newbie
  • *
    • Antal inlägg: 38
    • Visa profil
  • Stad: Mölndal
COCS, spelet är inte ett WPC95-spel, utan ett av de som kom lite tidigare. Sen har jag alltså testat med en annan display och då gick det bättre, så det lutar ju väldigt mycket åt att displayen är kass. Men en sak jag gärna skulle vilja förstå är vad som kan ha hänt under transporten. Jag får lita på att säljaren aldrig haft detta problem, och säger att det måste ha hänt under transporten. Men frågan är vad? Kallödningar på displaykortet (även om jag inte kan se någon) som oturligt nog gav upp just nu, ...?

are, jag har inte testat displayen i ett annat WPC-spel. Har ett LOTR som jag skulle kunna testa den i men vet i fasen om jag vågar det. Om det nu är den dåliga displayen som "grillat" kontrollkortet så att åtminstone två komponenter gått sönder (en transistor var ju dessutom så där glansigt grön som de kan bli när de går varma under en längre tid), så är det väl inte helt riskfritt att sätta in den i något spel överhuvudtaget?

Annars, brukar det gå så hett till på displaykontrollkortet som det ser ut att ha gjort på detta (se bilerna i mitt första inlägg)? Om inte har jag ju åtminstone nu lärt mig att man ska kolla upp det innan man köper ett spel..


Calm

  • Hero Member
  • *****
    • Antal inlägg: 750
    • Visa profil
  • Stad: Eskilstuna
AFR: Om du kör displaytesten hur ser displayen ut då? Fortfarande dålig? Kolla pinrepair där står det om "Cloudy Dot Matrix Display".

http://www.pinrepair.com/wpc/index3.html#dots


AFR

  • Newbie
  • *
    • Antal inlägg: 38
    • Visa profil
  • Stad: Mölndal
Calm, jag körde displaytest samma dag som jag hämtade spelet, och det blev dimmig display lite till och från beroende hur många punkter som borde vara tända, ungefär som det beskrivs på pinrepair (har spelet i stugan så jag kan inte testa just nu för att vara säker, men har för mig att det t.ex såg bra ut vid "radtestet"). Där står ju också att detta problem ofta är värmerelaterat, och borde lösa sig om man byter ut komponenterna på högspänningsdelen. Men det har jag gjort, och det hjälpte alltså tyvärr inte.

Har läst på flera ställen att skillnaden mellan pin1 och pin2 måste vara 12 V. Men den blir alltså lite drygt 20 V med denna display inkopplad. Någon som vet var man kan hitta ett kopplingsschema till kortet som displayen sitter fastlödd på? Kanske man kan klura ut om det kan vara någon trasig komponent på det kortet som lastar pin2-spänningen på fel sätt?