Frispel

sedan 2001

Data East transformator - spänningar?

Luma

  • Sr. Member
  • ****
    • Antal inlägg: 383
    • Visa profil
  • Stad: Vara
Hej alla.
Är det någon som har en lista på vilka spänningar som skall komma ut ur trafon på ett Star Trek (Data East -91).

Har låga spänningar till högvolten på DMD:n vilketresulterar i nada DMD-aktivitet.
5 & 12v är perfekt och maskin bootar som den skall.

Maskinen har varit körd i ett tidigare liv en längre tid med dålig DMD så detta är resultatet/orsaken antar jag.

Jag vet att det mycket väl kan vara power-kortet som strular, men vill vara säker att det inte är längre ner i kedjan.

// Luma
// Christer


Luma

  • Sr. Member
  • ****
    • Antal inlägg: 383
    • Visa profil
  • Stad: Vara
Hmm.

Jag hittade spänningarna i manualen till Batman, som har samma trafo & power-kort.

Spänningarna stämmde från trafon så det är dags att gå vidare till power-kortet.

Vänligt nog fanns ett schema på 520-5047-00 i batman-manualen också.

Nu... Är det någon som vet vilka komponenter som normalt brakar ihop i samband med HV?  Dvs. finns det några hv-kit (eller rättare sagt, vad ingår, jag orkar inte vänta på posten utan åker till elektronik-krängarn i byn).

// Luma
// Christer


Luma

  • Sr. Member
  • ****
    • Antal inlägg: 383
    • Visa profil
  • Stad: Vara
Igen.

Tja, när man väl började titta på schemat så var det ju inga konstigheter att hitta högvolts-konponenterna.

Ett par zenerdioder som jag inte tror dom har lokalt här bara, så det blir nog till att beställa en uppsättning med delar från elfa ändå.

// Luma
// Christer


Luma

  • Sr. Member
  • ****
    • Antal inlägg: 383
    • Visa profil
  • Stad: Vara
Ok, nu har jag ordnat alla spänningar i högvolten, men...

Jag får fortfarande inte igång DMD:n
Jag kan inte vara helt säker på att någon av dom två displayerna jag har är hela.

Börjar fundera på rom:et till grafiken.

När man startar upp maskin, och ska köra igång ett spel så börjar lampor pulsera (dhilitium-kristallerna), så här står den ca: 20-60 sekunder.

Troligen en timeout funktion.

När det sedan har hoppat igång så fungerar allt (ja, utan skärmen då förståss).

Har för mig att jag läst nått om en fix i rom som hindrar spelet från att hänga sig om cpu:n i grafidelen lägger av, en timeout och sen ska det fortsätta med med felaktig grafik.

Är det nån som vet om det är vanliga ttl-nivåer i datakabeln från dmd:n. Dvs., ska jag kunna se en skillnad (logiskt låg/hög 0v/5v) i "Display Enable" (pin 1) och borde det i så fall ite gå att lägga den hög (eller låg beroende på vilket) för hand med 5v/jord i startögonblicket och slippa timeout.

Om nån fattar vad jag menar, och om nån vet så ge gärna lite input.

// Christer
// Christer


Luma

  • Sr. Member
  • ****
    • Antal inlägg: 383
    • Visa profil
  • Stad: Vara
Japp, då uppdaterar jag denna tråd.

Det visade sig att jag kikade på fel schema, mycket klantigt.

Men, jag hittade ben 3 "Busy" vilket hade samma funktion som jag tänkt mig.

Och, denna hade 5v hela tiden, även efter "start". Genom att jorda den (lägga den logiskt låg) så starta maskin med en gång.

Så, troligtvis rom fel...

// Ch
// Christer


Luma

  • Sr. Member
  • ****
    • Antal inlägg: 383
    • Visa profil
  • Stad: Vara
Uppdatering


Fick äntligen mina rom:ar från usa, och spelet startade klockrent.... Så lätt kan det vara :-)

//Luma
// Christer


Tags: diod display DMD  rom   power