Författare Ämne: Problem med Metallica Pro  (läst 931 gånger)

Rainman

  • Newbie
  • *
  • Antal inlägg: 42
    • Visa profil
Problem med Metallica Pro
« skrivet: januari 22, 2018, 14:01:41 »
Har ett Metallica Pro med ett lustigt fel, då vänster flipper är aktiverad och bollen träffar vänster sling så registrerar gravemarker-opton en "träff", detta sker nästan varje gång men som sagt inte alltid. Kör jag switchtest och aktiverar de två switcharna så aktiveras inte opton men om jag kör switchtest med luckan stängd så coils aktiveras så aktiveras den nästan varje gång.

Trycker jag upp flippern manuellt så att EOS inte är aktivt längre och aktiverar slingshoten så händer ingenting.

Symptomen får mig att tro att en diod skulle kunna vara trasig någonstans men då det är rätt drygt att mäta dioder så undrar jag om jag är på rätt spår, skulle det kunna vara någonting annat som spökar? Det är alltså enbart vänster flipper + vänster sling, inte höger flipper + vänster sling eller någon annan kombination.

pellew

  • Newbie
  • *
  • Antal inlägg: 49
    • Visa profil
SV: Problem med Metallica Pro
« Svar #1 skrivet: januari 23, 2018, 15:57:05 »
Låter misstänkt som att en diod skulle kunna fela på spolen till slingshoten eller flippern, men mönstret verkar lite skumt. Om du har lösa dioder så kan du prova koppla dessa parallellt mellan dom som redan sitter där (temporärt med t.ex. krokodilklämmor) för att se om det löser problemet.

Det kan inte vara mekaniskt, att opton är dåligt linjerad, som gör att den "tappar" kontakten när spelet hoppar till av slingshoten? Borde iofs även hända när bara slingshoten aktiveras, men vem vet. Nånstans måste man ju börja felsöka.  :)

Hälsningar,
Pelle

Rainman

  • Newbie
  • *
  • Antal inlägg: 42
    • Visa profil
SV: Problem med Metallica Pro
« Svar #2 skrivet: januari 23, 2018, 17:15:00 »
Ja jag tycker också att om det vore mekaniskt borde det hända både utan och med flippern inblandad!

Lite ytterligare information för att komplicera det hela, om båda flipprarna är aktiverade och slingshoten aktiveras så ger det ibland både en gravemarker hit och en sparky hit! Känn på den. Och om båda flipprarna är aktiverade så kan även pop bumpers ge träffar på gravemarker/sparky opton.

Mailade Stern och frågade och fick ett snabbt svar från Chas där han trodde att opton var dålig, antingen givare eller mottagare, jag ställer mig dock lite tveksam till det för det skulle innebära att båda optos är trasiga (gravemarker/sparky). Det skulle såklart kunna vara optokortet som strular men varför det skulle börja registrera "spökträffar" förstår jag inte. I övrigt så fungerar optos exakt som de ska.

pellew

  • Newbie
  • *
  • Antal inlägg: 49
    • Visa profil
SV: Problem med Metallica Pro
« Svar #3 skrivet: januari 23, 2018, 18:02:39 »
Har kollat schemat lite: Gravemarker och sparky (electric chair?) delar samma optokort. Jag skulle nog se över det. Kolla kontakterna till det.

Spolarna verkar dessutom vara utan dioder direkt på spolen. Är nog övertygad att det inte är problemet.

Hälsningar Pelle

Rainman

  • Newbie
  • *
  • Antal inlägg: 42
    • Visa profil
SV: Problem med Metallica Pro
« Svar #4 skrivet: januari 24, 2018, 15:20:40 »
Japp det är samma optokort de går till, ser inga speciella fel med det och har reseatat kontakterna utan någon som helst förbättring.

Kikade i backboxen och en av transistorerna (Q15) ser ut att vara bytt av någon och det ser spontant ut som att den som bytt den inte gjort ett speciellt bra jobb. Q15 driver vänster flipper så det ligger ju helt i paritet med vad som orsakar felet. Det jag ställer mig frågande till är om en trasig/fel transistor kan ge upphov till sådana konstiga fel verkligen som spökträffar på optos?

pellew

  • Newbie
  • *
  • Antal inlägg: 49
    • Visa profil
SV: Problem med Metallica Pro
« Svar #5 skrivet: januari 24, 2018, 18:50:08 »
Prova byt optokortet med något av de andra och se om problemet försvinner eller flyttar sig. Jag skulle fortfarande misstänka det.

Hälsningar Pelle

Rainman

  • Newbie
  • *
  • Antal inlägg: 42
    • Visa profil
SV: Problem med Metallica Pro
« Svar #6 skrivet: januari 25, 2018, 09:24:52 »
Byte av transistor Q15 verkar ha löst problemet! Mycket märkliga symptom måste jag säga, kommunicerade med Chas på Stern och han sa att det var högst otroligt att det var transistorns fel, men men jag håller tummarna.  :D